Block chain not updating

Thx, but I don’t have time or interest for so much reading.

MrWho…
Lost computer power yesterday so didn’t shut down normally. Today block chain won’t sync any new blocks, stuck at the point where computer shut down. Remembered your suggestion to try lopping of some blocks but can’t find the above tests in wallet menus. Or is this something I need to enter in a CMD window? Really dread the thought that I might have to redownload the block chain again. The first time took a week. I’ve got the whole thing on disk, also saved a prior copy elsewhere partway thru the download process, Surely there’s some way to repair and recover it.
Thx

If you use Qbundle make sure it is version 1.4. If not you can use “File->Check for upgrades” then you will find a popoff feature under Wallet->Advanced

Thx. Finally found it, but first had to discover and fix a local bug.

My default browser has been Firefox 52. It uses Adobe Flash NPAPI version which has become problematical over the last year or so. It generates error messages on certain websites. I don’t mind and work around it. However I found out by accident that your Qbundle also uses Adobe Flash (apparently), and unfortunately that it causes errors and a malformed Qbundle GUI. For example clicking ID in top left pane of Burst wallet drops down an offer to copy ID or numeric account number to clipboard. But it wouldn’t copy. Totally dead to mouse or keyboard commands. To make a long story shorter…

The fix was to change my default browser to IE11 on this W8.1 box. It uses the standard Adobe Flash version which has never caused problems. I then saw some new features and options appear in Qbundle, the above mentioned copy to clipboard operation works OK, and I found the Popoff operation. So it seems that Qbundle depends on system’s default browser & associations, including the Adobe Flash add-on version. Surprised me.

The Popoff operation duly lopped off blocks from the top of my block chain as commanded, but unfortunately that didn’t fix the problem. Firebird db totally refuses to restart downloading blocks after the local power outage and improper computer shutdown. It wasn’t a problem with the power company. I was tired, angry, turned off the power strip that supplies everything, and went to bed! I knew better. A couple of other softwares I had multitasking complained too, but repaired themselves. Qbundle didn’t.

So I’m starting from scratch again for the 4th time!? Now with the benefit of one less local bug (Adobe Flash/Firefox52), and your improvements in Qbundle since v1.3.1. I approve, but still wonder why the download of a few Gb database should take so long. It seems that my ATX 645 GPU is being used but only a small part of its capability. My lovely i4770 and 16 Gb RAM are also only slightly used.

In the meantime I must wait about 45 hours for the 6.6 million transactions to import. Actually that seems a misnomer. Qbundle v1.41 first downloaded a 1 Gb “something” which took only a few minutes. That was a genuine import. But getting the transactions is apparently only an internal calculation, perhaps a decompression of the 1 Gb import(?). Only GPU and hard drive are involved. Hard drive is flatlined at 95-100% usage. Nothing being input via internet, just a 8 kbps blip every 60 seconds, probably a keep alive signal. System memory and CPU are almost totally unused. I’m just guessing based on symptoms, haven’t looked at source code, but found the github link. Here’s a hodgepodge graphic of what I see…

Hi again,

Qbundle in itself is only a wrapper and controll center for the core wallet that is written in java. It’s intention is to simplify the usage of the wallet.Qbundle uses built in IE on the machine, nothing else. Core wallet (NRS 1.3.6cg) uses flash if found on system for a clipboard copy function but if it is not installed it tries to use a html5 function for the clipboardcopy.
As mentioned erlier firebird is the most slow database and might not be best suited. there has also been other discoveries since we talked about this erlier that firebird might not be the best option at all and might be prone to be stuck. If you use GPU acceleration you should not see much usage at all since it is only used to calculate shabal256 algorithm which is cpu heavy. If your disk is at 100% then there is a bottleneck.

Unfortunately that was ghost download. No changes to Firebird DB. So I decided to clear computer of all the Qbundle and Burst scraps and start clean with v1.4. This time with benefit of IE11 as default browser and used in all related operations.

Clearly it’s working correctly this time! I don’t have to look at any system processes because it’s lickety-split compared to anything I’ve seen previously. The whole process may only take an hour or two then I can catch a few well-deserved zzzzz’s :slight_smile:

It looks like whatever op system is used may benefit from defaults for everything, particularly browser. It’s getting time to retire Firefox anyway except the older version still runs some useful add-ons.

Thanks for everyones’ patience while I ferreted out the cause of this frustrating problem. Not easy job. Hopefully smooth sailing ahead ~~~ :blush: )

1 Like

It doesn’t work on this W8.1 puter. :frowning: H2 stalled at same position as prior Firebird hung (after a local power outage) and won’t budge. Now local wallet refuses to start. It puts some complicated data in registry, so recommend a windows installer/uninstaller to clean up afterwards. Lack of built-in help, tooltips, etc in GUI is also discouragement. During the brief period when it was working, I had no idea how to buy/sell a coin. Take user gently by the hand and lead through one successful transaction. Maybe I’ll look again later with a little W10 laptop I bought myself yesterday, still leaning on desk in original cellophane.

Just got the Burst blockchain downloaded via Qbundle v1.5. Thanks Q.

It fixed all problems I had with prior versions, as discussed above in this thread. It now seems stable, at least a solid beta status. Having a reliable setup is fundamental to confidence of users.

I was using a new W10 notebook (initially) in my latest try. It overheated after an hour or so, black screen, shut itself down. That’s a common problem with notebooks/laptops, probably needs better quality of thermal grease on the processor. After turning it back on and opening the wallet, it resumed downloading blockchain without loss of prior data. I tested this by pulling the power plug intentionally, and there was no problem. I let it go another 24+ hours (no more black screens) and got about 2/3rds of blockchain downloaded. It behaved very nicely, restoring my confidence to give W8.1/i4770 desktop another chance…

Again I found it necessary to make IE11 default browser on W8.1/i4770 or there were wallet malfunctions. I kept Firefox, normally my default browser, but uninstalled NPAPI Flash which it uses. Firefox will have to reside in the wings for awhile.

Whatever was hanging the W8.1/i4770 system, preventing blockchain download past the prior power outage interruption (discussed above in this thread), didn’t reoccur. It breezed through the blockchain download in good fashion. I didn’t time it, took maybe 16 hours. System strain much less. No problem with hard drive flatlining at 100% usage like with prior Qbundle versions. There was only a brief period of 100% hard drive usage at the start. Everything seemed balanced with better usage of processor, hard drive, and GPU. Generally downloaded about 300-350 blocks/minute, increasing to about 400 blocks/minute towards the end. That’s about 2-3x faster than the new little W10 notebook. Final size of db about 6.5 Gb, a reasonable amount.

The only problem was hogging system resources, so I could scarcely get email on my LAN!? Hopefully I can fix that by reducing #processor cores used, or maybe the GPU speedup isn’t needed to maintain an up-to-date chain. A “Pause/Resume” button might come in handy for those of us who need to multitask occasionally.

Now I must figure out how to setup the account and acquire some Burstcoins. It’s not automatic. There’s some unusual hurdles!? It’s not like opening a bank or credit card account with immediate access. Removing the catch 22’s, making it more automatic would be very helpful.

#1 is apparently to enter a name for the account. That costs a 1 coin fee, but I have no coins yet. How? What name should I use, and what description should I give the account? Can it, or should it, be a pseudonym? Can it be changed later? Also I’m like a babe in the woods. What info is OK to make public or keep private?

What I really need is a mentor to lead me gently by the hand for awhile, through the preminary account setup, and acquiring a few coins to help get things started. I’m not interested in mining at this point, and simply want to invest (buy/sell coins). I have an idea for a unique storefront later. In lieu of a kind-hearted volunteer here, I’m willing to pay a suitable fee. Is there a standard amount? I’ll arbitrarily offer 100 Burstcoins (when I get them) or any other mutually agreeable amount/method. I see the Burst wallet has a messaging service. Would it be appropriate to mention my account ID here for that purpose? Or will the wallet’s messaging system work before the account is setup? I could also provide an email address or fax number, if that’s acceptable, but prefer to avoid the telephone. I don’t have (nor want) a cell phone, and I do not “text”.

I’m fairly eager to get going!
Thanks.

I’m glad you made all work. There is only one thing you should never show another person and that is your passphrase/seed that you use to login to the wallet. All other data that you can see when it comes to name,account nr, nummeric accountnr, public key and so on is Available for everyone to see. This includes things like how much funds you have in the wallet and such. Oh, yea messages that are marked “encrypted” is not readable to anyone but everyone can see that there is one and can see the encrypted text. To fund your account with a small amount to get started you can ask in one of the threads on any forum were ppl ask for money. or use faucets. Discord chat can also be an alternative.

[quote=“Quibus, post:20, topic:1208”]
great video is about blockhain in bitcoin
[/quote] very informative video

Still baffled by tech problems…

My local wallet on W8.1/i4770 desktop computer is resilient so far, hasn’t failed to start or update/sync. But considering the problems I’ve experienced installing local wallets with Qbundle 1.4-1.5-1.6, I wouldn’t bet it will open next time. It has been shut down for a week or so while I’ve been busy elsewhere. To try it again, necessary to change a setting in dumbed-down Two Wire (Pace 5031NV-060) modem/router firewall which will only allow one computer to access the same special port (“pinhole” in ATT lingo) on LAN simultaneously. No universal port mapping. Not the ideal but I can probably manage.

I feel that I need at least 2 different computers with working local wallets to invest with a fair chance of recovery. One for backup. Of course I wouldn’t try to run both simultaneously on same LAN.

I’m still hung on trying to get a 2nd local wallet working, on my new W10 Notebook. I’ve tried all the database downloads, even exported one from my other computer then tried to import, but all go to the same problem: Wallet will not start. Perhaps immediately as after downloading the Cryptoguru database, or after shutting down and restarting as with Burstneon database which had proceeded to update & sync everything OK initially.

Switching to a public wallet goes OK, but then trying to switch back to local wallet, says: it checked and API on port 8125 is not running. Of course I knew that already. :wink: Double-checking ports 8123 & 8125 were properly open for inbound connections in Windows Defender and router firewall. Are any other ports required? Looking at console or nxt.log shows Java exceptions. Knowing nothing about such things, does this copy of nxt.log tell what’s wrong?


[INFO] 2017-12-28 16:24:16 LoggerConfigurator - logging enabled
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.maxRollback = “1440”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.isTestnet = “false”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.isOffline = “false”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.dbUrl = “jdbc:h2:./burst_db/burst;DB_CLOSE_ON_EXIT=False”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - burst.enableSqlMetrics = “false”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.dbUrl = “jdbc:h2:./burst_db/burst;DB_CLOSE_ON_EXIT=False”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.dbUsername = “sa”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.dbPassword = “sa”
[INFO] 2017-12-28 16:24:16 nxt.Nxt - nxt.dbMaximumPoolSize = “10”
[INFO] 2017-12-28 16:24:16 com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Starting…
[SEVERE] 2017-12-28 16:24:20 com.zaxxer.hikari.pool.HikariPool - HikariPool-1 - Exception during pool initialization.
org.h2.jdbc.JdbcSQLException: General error: “java.lang.NullPointerException” [50000-196]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:345)
at org.h2.message.DbException.get(DbException.java:168)
at org.h2.message.DbException.convert(DbException.java:295)
at org.h2.engine.Database.openDatabase(Database.java:307)
at org.h2.engine.Database.(Database.java:270)
at org.h2.engine.Engine.openSession(Engine.java:64)
at org.h2.engine.Engine.openSession(Engine.java:176)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:154)
at org.h2.engine.Engine.createSession(Engine.java:137)
at org.h2.engine.Engine.createSession(Engine.java:27)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:354)
at org.h2.jdbc.JdbcConnection.(JdbcConnection.java:116)
at org.h2.jdbc.JdbcConnection.(JdbcConnection.java:100)
at org.h2.Driver.connect(Driver.java:69)
at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:117)
at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:123)
at com.zaxxer.hikari.pool.PoolBase.newConnection(PoolBase.java:375)
at com.zaxxer.hikari.pool.PoolBase.newPoolEntry(PoolBase.java:204)
at com.zaxxer.hikari.pool.HikariPool.createPoolEntry(HikariPool.java:445)
at com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:516)
at com.zaxxer.hikari.pool.HikariPool.(HikariPool.java:116)
at com.zaxxer.hikari.HikariDataSource.(HikariDataSource.java:72)
at nxt.db.sql.Db.(Db.java:130)
at nxt.Nxt$Init.(Nxt.java:245)
at nxt.Nxt.init(Nxt.java:202)
at nxt.Nxt.main(Nxt.java:193)
Caused by: java.lang.NullPointerException
at org.h2.mvstore.db.ValueDataType.compare(ValueDataType.java:104)
at org.h2.mvstore.MVMap.compare(MVMap.java:713)
at org.h2.mvstore.Page.binarySearch(Page.java:334)
at org.h2.mvstore.MVMap.binarySearch(MVMap.java:466)
at org.h2.mvstore.MVMap.get(MVMap.java:455)
at org.h2.mvstore.MVMap.remove(MVMap.java:543)
at org.h2.mvstore.db.TransactionStore.rollbackTo(TransactionStore.java:506)
at org.h2.mvstore.db.TransactionStore$Transaction.rollback(TransactionStore.java:803)
at org.h2.mvstore.db.MVTableEngine$Store.initTransactions(MVTableEngine.java:256)
at org.h2.engine.Database.open(Database.java:767)
at org.h2.engine.Database.openDatabase(Database.java:276)
… 22 more

Another peculiarity. After downloading the Cryptoguru database and letting it proceed to the point of reopening wallet automatically, an error message popped up saying that a different wallet was already running, offering several complicated options how to proceed. How could that be? I didn’t intentionally start another wallet and had of course restarted computer after prior manipulations! Having no idea what to do, I pulled out my lucky silver dollar and let it decide with coin tosses. Then of course local wallet refused to start, as they all do eventually. Chopping off a few blocks never helps.

I’ve already exhausted most of my seat of the pants ideas. Common sense tells me something is blocking. What? Is it possible for an internet service such as ATT to do so? Or how about Microsoft which reportedly isn’t very friendly with some p2p software? (This is my first W10 box so that’s only hearsay.) In support of the latter, the first time I tried running the wallet setup, it warned me it was dangerous software that might harm my computer. It allowed me to bypass and run it anyway. I haven’t seen that particular warning again.

I personally have no idea what is causing your problems. I have a pretty vast array of machines that I have installed Qbundle onto, and they all are working fine…I just know that one needs Windows 10 64-bit. I also have installed Java 64, but Qbundle can manage that for you. Any antivirus will most likely mess with this as well.

I’m still trying but no joy yet on this new W10x64 notebook. In my latest attempt I reinstalled W10 clean, removed an unneeded OEM firewall/antivirus, and made a few other tweaks that might help. I then ran the wallet.exe file in Qbundle v1.6, selected the neon db, and it went amazingly fast. The neon db was downloaded in 51 minutes, converted to blockchain in another 10 minutes, then started updating itself immediately. That was a bit sluggish but everything was in fully synchronized in another 25 minutes. Total only about 90 minutes!

At that point everything behaved normally, as far as I could see. I tried looking at other wallets in the dropdown list, then went back to local wallet, no problem. I could also exit then restart local wallet. Everything appeared to be working perfectly. But I had achieved this in the past. With fingers crossed, I restarted computer which ended my joy: WALLET WILL NOT START

So there’s something about restarting computer that kills it. What? I can only speculate. Might be some kind of block in Windows Defender, which complains when I first try to run the wallet.exe file but let’s me bypass. They say they’re unhappy with certain aspects of the software but don’t offer details. I took many screenshots along the way and will zip and upload for anyone to see.

I’ve tried reading the instructions for how to run Qbundle but they’re not of help–long out of date, for the old v1.2.9 version. For example they mention a RUN.BAT file which isn’t in current Qbundle versions. I thought it might give a clue but can’t find it at GitHub. However there’s a slight ray of hope. It mentioned the proper way to close the software is hold down Ctrl key and press C key twice. I haven’t seen that mentioned elsewhere. I’ve been careful to use the exit option from file menu but obviously that’s not enough. Some better recovery or autorepair function is needed to handle power outages of other unexpected disconnections.

Frankly I find this a mixed-up mess with total lack of proper operating instructions. I took it upon myself to run the wallet.exe file. Is that the proper way to start this software? What happened to the RUN.BAT file?

It’s impossible to know what else that’s important might be missing. For example I discovered by lucky accident that holding down the Ctrl key and scrolling with mouse wheel zooms in/out the wallet. I saw a couple of new buttons at bottom of left pane I’d never seen before because they aren’t automatically resized with wallet nor is a separate scroll bar offered for left pane of wallet.

Personally I believe the wallet has too many dependencies. There’s nothing that needs more than simple html1. I’d cut out the java, javascript, flash, and dependencies on IE and .NET. That would fix it, I imagine.

LEGEND for attached 23 PNG’s of attempted setup with Qbundle v1.6
-sequential screen shots of the process

1 specs for my new W10x64 notebook, used in this test

2 Run the wallet.exe, it first downloads portable Java

3 Continue, blockchain begins downloading immediately, but popup says Windows Defender has blocked some Java features on all networks

4-5 Allow access using default Private networks (should I have selected Public networks instead?), it continues to download blockchain

6-12 switched to the Neon db option in Database menu which stops wallet, imports & converts data in 52 minutes, then restarts wallet automatically

13 I had to click Close to dismiss the import box (shouldn’t that be automatic?)

14 all data in Neon import is added to blockchain in one big chunk

15-16 blockchain continues to update

17 blockchain is fully synchronized, wallet running!

18-19 all appears OK while I play around, open a different wallet, then local wallet again, etc

20-22 restarted computer which kills the wallet, will not restart, just a white screen, although Qbundle data still updates at top

23 switched to a different public wallet OK, but when tried to go back to local wallet it refused with 8125 error message. After many tries eventually it refused to switch to a different wallet as well.

Now you know as much as I do. :wink:

If wallet is killed. IE computer restarts the H2 database is prone to corrupt. One way that might fix the problem is to use the rollback chain option found under “wallet->Advanced”. Use default optiones when asked. and make sure wallet is started afterwards.

If that does not work i sugest you delete the contents in burst_db folder. Go to Database->Change database and choose MariaDB that is controlled by Qbundle. Download it when asked and choose no copy on the next screen.
Now i sugest you sync from scratch however if you like you can use the import function and sync from cryptoguru repository. It will not be as fast as with h2. probably take about 2hours or so. but you will have a more stable environment than before.

1 Like

This new little $199 notebook from Walmart had a .NET/font bug, plus W10 botched several attempts to upload the blockchain, interrupting with updates and restarts; I believe both are fixed now. I installed the missing HP Simplified fonts and disabled the Windows Update service. If anyone knows a better way, let me know!

I should have blockchain uploaded here, plus on another computer already, so am getting ready to play game! How does this sound…

I’d like to acquire some Burstcoins and can offer a collector grade 1 oz Platinum bar. Here’s some recent prices from goldprice.org and Qbundle v1.8 to give a general idea (US$). If interested please let me know. Thanks. BURST-VRRP-SRG5-BYCK-86VBC

Plat    Burst	Burst
spot    coin	coins
====    ====	====
958  /  .086 =  11139
957  /  .087 =  11011
959  /  .084 =  11416
960  /  .078 =  12307
1 Like

Don’t know what will become of it, but put up a placeholder page for Burst on my website at: burst.johnnybob.com (nice graphic)

Close family and a few Facebook friends know I’m interested. Maybe they remember my asking several years ago if we should get into Bitcoin? The response was a resounding No! Now they’re not so sure. :slight_smile:

Still rummaging around to familiarize myself with wallet options and history. Lots of googling involved. For example “Burst RS” occurs on the account signup page without definition, but has its own wiki. Many of the googles refer back to these forums. I expect everything is available but can’t predict how long the self-education process will take – a week, month, or year.

It’s a fairly complicated subject. For example I had to ask some basic questions such as: Is there a universal wallet that will hold any cryptocurrency? Also important is liquidity. How easy is it to move from one currency to another, or get in/out of crypto? Also how does crypto relate to traditional havens such precious metals, gems, etc.?

I’m becoming doubtful that I can continue unless someone volunteers as a personal mentor. Too much for me to learn on my own, an infinite series of googles. I’m generally knowledgeable about computers and software, but my only prior experience with cryptography was a Red Ryder decoder ring on the radio ca 70 years ago.

So your flashy graphics enticed me to download Burst wallet and take a look around. Qbundle takes it up to that point, nicely in v1.9 which seems almost error proof now, but stops. User is dropped abruptly as if we should know how to proceed. Catch 22.

So I guess those are my best suggestions. Either start a personal 1:1 human mentoring program, or extend Qbundle through filling out account (and any other required) forms, registration, finding someone who’s interested in making a transaction, arriving at a final agreement, then the first buy & sell transaction–explaining everything along the way. I favor a personal mentoring program involving humans, where each student who graduates agrees to become teacher for two others in future, thereby fulfilling their debt and propagating it.

Maybe the process could be translated into a computerized tutorial and/or video later.

[P.S. FYI, Brad Cohen mentions Burstcoin in his recent update. Obviously it’s a different system. I’ve long been aficionado of his torrent protocol, but must reserve judgement. Seems to me users will lack motivation due to limits on profits/mining in Chia, also wonder about local network slowdowns. Nothing is written in stone yet.]

ho hum +
ho hum (10 characters required)
to express basic disinterest…

Im in Africa, Angola and its taking ages…4 days now. This is not normal.