Discussion Thread For New Testnet


#41

Thanks :slight_smile:
Not easy to setup a local wallet.


#42

I tried to sync a 1.2.9 Wallet to your TestNet yesterday but always got stuck with an nxt.BlockchainProcessor$BlockNotAcceptedException: Calculated remaining fee doesn't add up error!?

And then I started mining a few Gb’s against your wallet “http://176.9.47.157:6876” and… forgot about it! :innocent:
hope I did not cause any grief!

So…, the only thing I confirm is that you can perfectly use the integrated GPU of an low power Intel N3700 with jminer to mine a few Gigabytes!


#43

You can try spamming the testnet, although I think it was one of the 1st things that had been tried with it. (During the test we could verify that higher tx fees = higher priority)


#44

Problem with testnet right now is that the block count is so low. There was a change in the Transaction handling from version 0 to version 1. Any functions such as subscriptions and escrow or similar will break the testenet. Either we need to patch the wallet to use version 1 for all blocks or we need to leave anything but basic functions alone untill we get past the block 11800. Else everyone will end up in their own fork when mining.


#45

Hi,
Please send me test-BURST to:
BURST-5TTB-MR8P-TW7M-4MUEM
Thanks!


#46

Burst sent!


#47

Got it. Thank you!


#48

Tried on several PCs - can’t download test db after block 1670.
Any idea why is that?


#49

Which wallet are you using? You should try the newest CG wallet. In the course of testing/bashing the testnet, we found quite some problems that hung the older versions.


#50

Tnanks, but…
Installed MariaDB and setup correctly.
Used the latest 1.3.4cg wallet.
Still can’t reach after block 1670. (I see downloaded blocks in MariaDB.)
Seems that the testnet peer is outdated.
Are there other testnet peers to use in this situation?


#51

There are some problems with the wallet code.
The problem you see is with a SubscriptionTransaction

src/java/nxt/Subscription.java

There was a subscription transaction generated on the testnet - of course the wallet had only hardcoded new protocol versions. So if you look ~ line 300 in the file mentioned above, you see

TransactionImpl.BuilderImpl builder = new TransactionImpl.BuilderImpl((byte) 1,

where you would have to change the 1 for a 0
compile and run your wallet for the sync.


#52

Are the coins mined on the test net actual Burst coins or test-Burst?


#53

Testnet coins only. Look at it as a different coin using same technology


#54

Can i have some test-BURST to start:
BURST-X3D8-2ZFQ-C5XE-DAM5X
Ty!


#55

I have sent 2,000 Burst to your test wallet. Thank you for taking advantage of the Test Net!


#56

The testnet stopped at block 11801. Will it operate again?


#57

Should run again.
Please feel free to ping me on the discord channels anytime this happens.

It’s kind of to be expected, because the TestNet is subject to way more rigorous “experiments” than the Mainnet, giving us quite some insight about what to look at in wallet development.

edit:

More specifically, the reason for that wallet crash on TestNet was a Subscription Transaction with a wrong protocol version number (because that did change at block 8500 and was hardcoded in).


#58

howdy, i would like some funny money to play with so please send some test-burst to BURST-X47R-H7SX-KTVC-HW7TT

notes on syncing testnet chain: failed at block height 1671 (error about fees not adding up), tried rico666’s fix above but there are no subscriptions in the database at this height (the patch causes errors later in chain when there are subscriptions). so added a testnet check to the conditional throwing the error ( github.com/damncourier/burstcoin/commit/79a4256a94edca871c1690aab687cda4a6504307 (forum won’t let my new account include links) ) which seems to working on current 1.3 source tree (1.2.9 hangs at 1679 without logging an error). the problem seems to be caused by fees added to blocks without transactions in them, no idea what that is about but it is a testnet so… whatever.


#59

Sent you some testburst!


#60

thanks, ryanw