Mac mining "Unable to get mining info from wallet"


#1

howdy

so i’ve set up jminer on my macbook, and created a plot (very small, 10GB, just as a test). I followed the instructions for setup found here. When I run the script:
sh run.sh
i get the following error message repeatedly:
2018-03-08 16:04:37.139 WARN 8905 --- [askExecutor-289] b.j.c.n.t.NetworkRequestMiningInfoTask : Unable to get mining info from wallet.

i’ve left it running the script in the hope that it’s just waiting for my wallet to appear in the pool (i’m in https://0-100-pool.burst.cryptoguru.org/ by the way), but i no tutorials suggested this would happen.

any ideas?


#2

I don’t have experience with jminer, but you should post your config.


#3

Good shout.

Config is:

plotPaths=/Users/[redacted]/burstmining
poolMining=true
numericAccountId=[redacted]
poolServer=https://0-100-pool.burst.cryptoguru.org:8124
walletServer=https://wallet.burst.cryptoguru.org:8125     
refreshInterval=2000
updateMiningInfo=true
connectionTimeout=12000

i’ve seen elsewhere that walletServer can be left blank; tried that too, same outcome.


#4

I may have heard other people talking about trying different jminer version as well…

I am also going to tag @drownedcoast as he has written some very good articles for Burst regarding Mac.

Also, to add onto this, I had this step-by-step saved in a text file for Mac -

Mining:

Use burstcoin-jminer

Link: https://github.com/de-luxe/burstcoin-jminer/releases

Download and modify file named ```jminer.properties````. I did as below, you do with your data where needed.

plotPaths=/Volumes/ArchiveRB/plots,/Volumes/ArchiveRB/plots/plot2

poolMining=true

numericAccountId=6891xxx9176xxx3xxx

poolServer=http://pool.burstcoin.eu

walletServer=http://pool.burstcoin.eu:8125

refreshInterval=2000

connectionTimeout=120000

Leave other conf as it is they’ll take the default value. This file has very good explanation hope you’ll find that very helpful.

Now go to into that directory using terminal and press command like below:

sh run.sh


#5

oh! got it!
for posterity, in case anyone else has this issue, i cleared the walletServer= field and changed poolServer=https://0-100-pool.burst.cryptoguru.org:8124 to poolServer=https://0-100-pool.burst.cryptoguru.org


#6

Follow-up possible issue: my address (BURST-9ACB-3NHM-394U-47XLG) isn’t showing up on the “All Miners” tab in the mining pool. Is that a problem?


#7

It more than likely that your 10GB is not generating a deadline good enough to send to the pool. If jminer seems to be running correctly, then I would say it’s just a capacity issue.

Thank you for updating your problem as well!


#8

that’s what i was starting to wonder. could you explain in a nutshell what a deadline is? i’ve read the word in a few places and can’t find a consistent definition.

any idea what minimum plot size i’d have to create to get into the mining pool? i’ve upped it a bit, but i’m doing this on a laptop that i use for everything so i kinda don’t want to block out a huge region for blockchain experiments. i’m getting a more powerful desktop machine soon so my plots will be increased massively (i’m looking at 60TB internally and scope for USB3 expansion externally) but i’m stuck with this for the time being.

no problem. sharing knowledge is how communities thrive.


#9

Sure, I’ll try to keep it simple.

Burst mining is similar to a lottery. The amount of space you have plotted is directly related to the number of lottery tickets you have. The tickets are piece to solving a problem.

Every block, a problem is sent out. The miners look through all their tickets and find the one that would help solve the problem the fastest. The deadline is how fast they can solve the problem using their best ticket.

The pool you are using requires a deadline of at least 1 year to be sent in. It may take some days for you to find one this low with your 10GB. I am guessing you don’t have a lot of free space, because I would say try 100GB and maybe you would see some results. Even then, the returns would be a long term average of 0.1 Burst per day with 100GB :slight_smile:

Here is the long version explanation of mining. Technical information about mining and block forging


#10

thanks for that. i understood the basic ‘lottery ticket’ premise, it’s just the terminology i’m unsure about. i won’t lie, still not 100%, but i’ll have a read of the long version and get my head round it.

just want to clarify my current understanding:

so the “tickets” are potential answers/solutions to the current block, and the miner picks the single best solution available to it? the deadline is the fastest possible solution time, so the lower the better?

as i said, i’ll read that post this weekend to get a better understanding.


#11

The tickets are a piece of the problem…meaning each ticket can find the solution, but at a different length of time; the deadline.

Yes, the lower the better. :slight_smile:


#12

got it! thanks so much for your help.
i’m now attaching any spare removable storage i can find, so hopefully i’ll get into the pool sometime soon.


#13

another follow-up. i found an old external 500GB HDD lying around so i’ve plotted that and all seems to be running okay. however, i still haven’t “won” (to use the lottery ticket analogy), and i think it’s because i’m now getting one of two errors in jminer, more or less every round:

e.g. 1.
dl '232831785' > '31536000' skipped
this one i understand; the deadline found is longer than 1 year, so too long for the pool.

e.g. 2.
dl '28025509' send (pool) [nonce '2036640']
dl '28025509' not accepted by pool!
dl '28025509' NOT confirmed! [ 324d 8h 51m 49s ]
i think line 1 means that the deadline is being submitted, but lines 2 and 3 are rejections, and there is no reason given. is it because they are higher than the current lowest submitted by someone else?


#14

No, the pool should accept your deadlines as long as they are under the limit no matter what everyone else submits.

I don’t have any experience with jminer…

Some questions though. Which pool are you using, and do you constantly get this error, or is it just occasional?

I read that you can add the flag debug=true to get more information regarding it.


#15

it looks like it’s every valid deadline that’s being rejected. i’ll add a debug tag and get back to you.

i’m using https://0-100-pool.burst.cryptoguru.org/


#16

you were correct. here’s a full error:

dl '12306098' send (pool) [nonce '50473']
dl '12306098' not accepted by pool!
Error code: '1008'.
Error description: 'deadline exceeds deadline limit of the pool'.
strange dl source '/Volumes/BURST500/2831538266509123913_0_1904000_1904000'
strange dl file chunks '1', parts per chunk '7', block '468503'
dl '12306098' NOT confirmed!  [ 142d 10h 21m 38s ]
strange dl result '-1', calculated '12306098' block '468503' nonce '50473'

would it be worth formatting the disk and re-plotting it from scratch? at 500GB it shouldn’t take very long. . .

UPDATE: just tried re-plotting and it looks as if the plot didn’t work first time round. the script had reserved the drive space (so the 500GB drive showed as ~100MB available), but looks like that plot hadn’t been populated with nonces. i’ve tried slightly different settings in the plotting and it appears to be working correctly.


#17

Ahhhh yeah good :wink:

I wanted to make sure first that the pool or connection wasn’t the issue before saying replot :wink: No one likes to do that if they don’t have to.