Miner won't start after update


#1

Just updated (or so I thought) and now my miner won’t start. I updated, but when I look for updates, it tells me the current version is 2.0.0, and the available version is 2.0.1 I have been through the process 3 or 4 times now, click download updates, get a pop up asking if I want to stop the wallet - It must be stopped before updating the components, click yes, get message saying Qbundle will restart after update. update window runs, closes and i am back to the Qbundle will automatically restart after update. It starts again, closes and the wallet never restarts. If I restart manually, I am back to square one. At no point will the miner start working again. I click “start mining” and it is as if I have done nothing.

Any ideas here?


#2

Hi, there are some kinks being worked out with the new updates.
I recommend going back to 1.9 qbundle with 1.3.6cg wallet.

Here are some notes regarding the new releases:


#3

How long should we anticipate before this is worked out? Going back to 1.9 allows me to open the wallet, but it won’t start. Going with the update and attempting to rollback does nothing also – I get stopped on the starting wallet in debug mode for hours, and nothing happens. And https://50-50-pool.burst.cryptoguru.org/ shows me as an unknown account with no history. (not sure if this means I lose everything I have mined or not, but it is frustrating)


#4

Not sure if this is relevant, but I looked in the BRS file in the folder, and got this. Looks like it is encountering an error and shutting down when I try to start the wallet (I had the folder open and caught a BRS file flashing in and out when I was trying to manually start, so I opened the text file – Again, I’m not a programmer, so I don’t know the significance.)

[SEVERE] 2018-04-01 15:37:12 com.zaxxer.hikari.pool.HikariPool - HikariPool-1 - Exception during pool initialization.
org.h2.jdbc.JdbcSQLException: General error: “java.lang.NullPointerException” [50000-196]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:345)
at org.h2.message.DbException.get(DbException.java:168)
at org.h2.message.DbException.convert(DbException.java:295)
at org.h2.engine.Database.openDatabase(Database.java:307)
at org.h2.engine.Database.(Database.java:270)
at org.h2.engine.Engine.openSession(Engine.java:64)
at org.h2.engine.Engine.openSession(Engine.java:176)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:154)
at org.h2.engine.Engine.createSession(Engine.java:137)
at org.h2.engine.Engine.createSession(Engine.java:27)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:354)
at org.h2.jdbc.JdbcConnection.(JdbcConnection.java:116)
at org.h2.jdbc.JdbcConnection.(JdbcConnection.java:100)
at org.h2.Driver.connect(Driver.java:69)
at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:117)
at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:123)
at com.zaxxer.hikari.pool.PoolBase.newConnection(PoolBase.java:365)
at com.zaxxer.hikari.pool.PoolBase.newPoolEntry(PoolBase.java:194)
at com.zaxxer.hikari.pool.HikariPool.createPoolEntry(HikariPool.java:460)
at com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:534)
at com.zaxxer.hikari.pool.HikariPool.(HikariPool.java:115)
at com.zaxxer.hikari.HikariDataSource.(HikariDataSource.java:81)
at brs.db.sql.Db.init(Db.java:95)
at brs.Burst.loadWallet(Burst.java:196)
at brs.Burst.init(Burst.java:176)
at brs.Burst.main(Burst.java:157)
Caused by: java.lang.NullPointerException
at org.h2.mvstore.db.ValueDataType.compare(ValueDataType.java:104)
at org.h2.mvstore.MVMap.compare(MVMap.java:713)
at org.h2.mvstore.Page.binarySearch(Page.java:334)
at org.h2.mvstore.MVMap.binarySearch(MVMap.java:466)
at org.h2.mvstore.MVMap.get(MVMap.java:455)
at org.h2.mvstore.db.TransactionStore.commit(TransactionStore.java:349)
at org.h2.mvstore.db.TransactionStore$Transaction.commit(TransactionStore.java:783)
at org.h2.mvstore.db.MVTableEngine$Store.initTransactions(MVTableEngine.java:254)
at org.h2.engine.Database.open(Database.java:767)
at org.h2.engine.Database.openDatabase(Database.java:276)
… 22 more
[SEVERE] 2018-04-01 15:37:12 brs.Burst - com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: General error: “java.lang.NullPointerException” [50000-196]
java.lang.RuntimeException: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: General error: “java.lang.NullPointerException” [50000-196]
at brs.db.sql.Db.init(Db.java:108)
at brs.Burst.loadWallet(Burst.java:196)
at brs.Burst.init(Burst.java:176)
at brs.Burst.main(Burst.java:157)
Caused by: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: General error: “java.lang.NullPointerException” [50000-196]
at com.zaxxer.hikari.pool.HikariPool.throwPoolInitializationException(HikariPool.java:569)
at com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:555)
at com.zaxxer.hikari.pool.HikariPool.(HikariPool.java:115)
at com.zaxxer.hikari.HikariDataSource.(HikariDataSource.java:81)
at brs.db.sql.Db.init(Db.java:95)
… 3 more
Caused by: org.h2.jdbc.JdbcSQLException: General error: “java.lang.NullPointerException” [50000-196]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:345)
at org.h2.message.DbException.get(DbException.java:168)
at org.h2.message.DbException.convert(DbException.java:295)
at org.h2.engine.Database.openDatabase(Database.java:307)
at org.h2.engine.Database.(Database.java:270)
at org.h2.engine.Engine.openSession(Engine.java:64)
at org.h2.engine.Engine.openSession(Engine.java:176)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:154)
at org.h2.engine.Engine.createSession(Engine.java:137)
at org.h2.engine.Engine.createSession(Engine.java:27)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:354)
at org.h2.jdbc.JdbcConnection.(JdbcConnection.java:116)
at org.h2.jdbc.JdbcConnection.(JdbcConnection.java:100)
at org.h2.Driver.connect(Driver.java:69)
at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:117)
at com.zaxxer.hikari.util.DriverDataSource.getConnection(DriverDataSource.java:123)
at com.zaxxer.hikari.pool.PoolBase.newConnection(PoolBase.java:365)
at com.zaxxer.hikari.pool.PoolBase.newPoolEntry(PoolBase.java:194)
at com.zaxxer.hikari.pool.HikariPool.createPoolEntry(HikariPool.java:460)
at com.zaxxer.hikari.pool.HikariPool.checkFailFast(HikariPool.java:534)
… 6 more
Caused by: java.lang.NullPointerException
at org.h2.mvstore.db.ValueDataType.compare(ValueDataType.java:104)
at org.h2.mvstore.MVMap.compare(MVMap.java:713)
at org.h2.mvstore.Page.binarySearch(Page.java:334)
at org.h2.mvstore.MVMap.binarySearch(MVMap.java:466)
at org.h2.mvstore.MVMap.get(MVMap.java:455)
at org.h2.mvstore.db.TransactionStore.commit(TransactionStore.java:349)
at org.h2.mvstore.db.TransactionStore$Transaction.commit(TransactionStore.java:783)
at org.h2.mvstore.db.MVTableEngine$Store.initTransactions(MVTableEngine.java:254)
at org.h2.engine.Database.open(Database.java:767)
at org.h2.engine.Database.openDatabase(Database.java:276)
… 22 more
[INFO] 2018-04-01 15:37:12 brs.Burst - Shutting down…


#5

There is an update available now. Not sure if it resolve the wallet handing issue. If your wallet is working fine then I suggest waiting to see how this update goes.


#6

thanks. However, the problem right now is that the wallet won’t start.


#7

I have the same problem with the newest Qbundle. But Qbundle version 1.9 (on a different system) is working for me. I suggest switching to version 1.9 or wait for a new version to be released. I am sure the developers are busy trying to work out the issues.


#8

I understand all of this is frustrating. The current release has had a lot of kinks that they are working out…not a great time for new people just joining.

I believe that error means that the H2 database is corrupt.

I agree with @MichaelM that going back to the old one is the best route. https://github.com/PoC-Consortium/Qbundle/releases/download/v1.9/Qbundle_1.9.zip

Extract that file into its own folder and run the burstwallet.exe. The best route is to have it sync from the beginning again.


#9

Ok. May be tomorrow before I get to it. I will try, and update you as to my success.

This is just to learn anyway. I don’t have a big enough outfit to be making anything substantial here. I do want to keep what I have mined, but I also have yet to mine enough to get a payoff


#10

In worst case you can use the online wallet at any time.
Just stick with 1.9 and save your blockchain and plotfiles before you reinstall. Saves you lots of time.

I also had the Problem with the 2.0.2 update; according to the console the error seems to be caused by Java.


#11

Since I have updated the wallet is running but it is no longer downloading and syncing the block chain. I think I will leave it with the updated version for now and see what happens over the next few days :):slightly_smiling_face:


#12

@starmanjones As always, I’ll be checking in at least one time per day :wink:

@Rixterminator You can try to pop off some blocks. First, see if there are any new updates available. Then go to Wallet ->Advanced -> Rollback Chain. Leave it at 100 and click rollback. Let it do its thing until it says it’s done. Don’t close anything. This will skim off some of the database and might allow you to sync up correctly.


#13

Hey guys, thanks for the feedback.
Earlier today I rolled back 1400 (max 1440) but the same thing is occurring ie: wallet and db are both running but the block chain is not syncing or updating and stuck back a few days since before I updated everything ( I am now running the latest of everything).
I’ll give it a few more days to iron out any bugs…:slightly_smiling_face:


#14

Tried deleting and reinstalling. I am running qbundle v1.9, wallet v1.3.6cg

Wallet won’t start. I tried the cryptoguru online wallet, nothing happens. I stay on the grey login page. I tried burst-team wallet 3, and i can log in, but the wallet won’t start, and the miner just rolls through grey/white text. So nothing is happening there either. Unless I am not finding the correct online wallet?


#15

How much Time did you give the wallet to start, is it just stuck in “Starting Wallet”? It takes really long, could be above 10-15mins.


#16

Make sure your firewall is not blocking the new update too


#17

I let it run for 24 hours. The folder I keep everything in is exempted from the firewall and AV. The wallet is not stuck in “starting wallet”. It starts, and within seconds changes to “stopped”.


#18

Have there been any updates or fixes in the last 3 days?


#19

I am thinking you db is possibly corrupted.

Qbundle is now at version 2.0.2 with wallet 2.0.3

You can download a bootstrap with the current version, not having to resync.


#20

I was wondering about that – how do I address the DB issue?