Qbundle wallet local not starting

Hello,
have a nice day everybody.

Maybe someone can point me to the right direction with the use of the qbundle wallet. I have the last version but i can not start the local db, regardless witch one i pick neither H2 nor mariadb is starting up.
-H2 just says stopped. If i click start wallet from the menu it tries than stops.
-Maria db gets stucked at starting.

Online works well.

I installed everything at least 2 times, java. exe and zip installation, etc and even reset win10 with “fresh start” and new install.
googled around but couldnt find anything that helped. I went also through tutorials but the db does not start.

Help would be very apprechiated.

thank you.

edit: correcting mistakes, if you find more just keep them :stuck_out_tongue:

1 Like

Ok, see you’ve done a clean install of everything, so I can only tell you some areas that can be causing problems…

  1. Antivirus doesn’t play well with it
  2. There are some issues with permissions
  3. Your firewall is blocking it

To get a better idea of what is happening, you will have to bring up the console. Edit -> View Console and see what errors it is showing.

2 Likes

Hello,
Thank you for your reply and help.

With MariaDB it shows:
180214 15:37:12 InnoDB: The InnoDB memory heap is disabled
180214 15:37:12 InnoDB: Mutexes and rw_locks use Windows interlocked functions
180214 15:37:12 InnoDB: Compressed tables use zlib 1.2.3
180214 15:37:12 InnoDB: Initializing buffer pool, size = 128.0M
180214 15:37:12 InnoDB: Completed initialization of buffer pool
180214 15:37:12 InnoDB: highest supported file format is Barracuda.
180214 15:37:12 InnoDB: Waiting for the background threads to start
180214 15:37:13 Percona XtraDB (http://www.percona.com) 1.1.8-29.3 started; log sequence number 1973873
180214 15:37:13 [Note] Plugin ‘FEEDBACK’ is disabled.
180214 15:37:13 [Note] Event Scheduler: Loaded 0 events
180214 15:37:13 [Note] D:!Mining!\Qbundle\MariaDb\bin\mysqld.exe: ready for connections.
Version: ‘5.5.29-MariaDB’ socket: ‘’ port: 3306 mariadb.org binary distribution

With H2 it shows:
Feb 14, 2018 3:37:14 PM nxt.Nxt getBooleanProperty
INFO: nxt.disableGenerateBlocksThread not defined, assuming false
[INFO] 2018-02-14 15:37:15 LoggerConfigurator - logging enabled
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.maxRollback = “1440”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.isTestnet = “false”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.isOffline = “false”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.dbUrl = “jdbc:mariadb://localhost:3306/burstwallet”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - burst.enableSqlMetrics = “false”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.dbUrl = “jdbc:mariadb://localhost:3306/burstwallet”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.dbUsername = “burstwallet”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.dbPassword = “burstwallet”
[INFO] 2018-02-14 15:37:15 nxt.Nxt - nxt.dbMaximumPoolSize = “10”
[INFO] 2018-02-14 15:37:15 com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Starting…
Exception in thread “main” java.lang.ExceptionInInitializerError
at nxt.Nxt$Init.(Nxt.java:245)
at nxt.Nxt.init(Nxt.java:202)
at nxt.Nxt.main(Nxt.java:193)
Caused by: java.lang.RuntimeException: java.lang.RuntimeException: Failed to get driver instance for jdbcUrl=jdbc:mariadb://localhost:3306/burstwallet
at nxt.db.sql.Db.(Db.java:143)
… 3 more
Caused by: java.lang.RuntimeException: Failed to get driver instance for jdbcUrl=jdbc:mariadb://localhost:3306/burstwallet
at com.zaxxer.hikari.util.DriverDataSource.(DriverDataSource.java:110)
at com.zaxxer.hikari.pool.PoolBase.initializeDataSource(PoolBase.java:342)
at com.zaxxer.hikari.pool.PoolBase.(PoolBase.java:117)
at com.zaxxer.hikari.pool.HikariPool.(HikariPool.java:109)
at com.zaxxer.hikari.HikariDataSource.(HikariDataSource.java:72)
at nxt.db.sql.Db.(Db.java:130)
… 3 more
Caused by: java.sql.SQLException: No suitable driver
at java.sql.DriverManager.getDriver(DriverManager.java:315)
at com.zaxxer.hikari.util.DriverDataSource.(DriverDataSource.java:103)
… 8 more
[INFO] 2018-02-14 15:37:15 nxt.Nxt - Shutting down…
Exception in thread “Thread-1” java.lang.ExceptionInInitializerError
at nxt.http.API.(API.java:96)
at nxt.Nxt.shutdown(Nxt.java:207)
at nxt.Nxt$1.run(Nxt.java:190)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.util.MissingResourceException: Can’t find bundle for base name javax.servlet.LocalStrings, locale en_US
at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1564)
at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1387)
at java.util.ResourceBundle.getBundle(ResourceBundle.java:773)
at javax.servlet.GenericServlet.(GenericServlet.java:95)
… 4 more

Maybe you can figure something out.
Thank you

Hello,

So I talked to Quibus, and he said it could possibly one of two things.

  1. Corrupt Qbundle file.
  2. Wrong version of Java installed.

Burst needs Java 64-bit to be installed.

First, go in and uninstall anything you have installed of Java. Remove it all.

Then download and install 64bit here http://javadl.oracle.com/webapps/download/AutoDL?BundleId=230542_2f38c3b165be4555a1fa6e98c45e0808

1 Like

TO ryanw

Thank you very much, this solved the issue.

On a personal note i like to congrat you for the effort you give on this forum, great!!!

1 Like

I’m very glad everything worked out for you. Also, thank you very much for your kind words, I appreciate it :slight_smile:

If someone installs on default path i.e. C:\Qbundle everything is fine, if someone choose a different path i.e. D;\Wallets\Qbundle than the problem starts. Thats verified with installing on those dofferent paths without touching the pc components and installed software. Esspecialy the subfolder makes troubles.

Edit; And for some reason except of c:\ instalation it has also problems if you use symbols in pathing.
The path that never worked regardles what i changed was D:!!Mining!!\Qbundle. Just the solution from ryanw helped until next reboot. I dont know why i am not an expert but i think reboots should not play any role on pathing

I have had issues with the paths myself as well. Without going into why on those machines, I just chalked it up to permissions issues. There’s nothing else running on them, so I wasn’t too interested in becoming a detective.