Wallet trouble


#1

My wallet was installed in April (1.3.6cg) and upgraded to 2.2.1 on the 18th of June. It made its way through the forks without a hitch but it seems to have now gotten stuck on block 514546. It says:

Jul 22 21:50:24 burstcoin java[10362]: [WARNING] 2018-07-22 21:50:24 brs.BlockchainProcessorImpl - A fork is detected. Waiting for cache to be processed.
Jul 22 21:50:24 burstcoin java[10362]: [WARNING] 2018-07-22 21:50:24 brs.BlockchainProcessorImpl - Cache is now processed. Starting to process fork.
Jul 22 21:50:25 burstcoin java[10362]: [INFO] 2018-07-22 21:50:25 brs.services.impl.BlockServiceImpl - Bad transaction signature during block pre-verification for tx: 11667679872393031107 at block height: 514546
Jul 22 21:50:25 burstcoin java[10362]: [INFO] 2018-07-22 21:50:25 brs.peer.PeerImpl - Blacklisting 213.32.102.141 (2.2.1) because of: during processing a fork
Jul 22 21:50:26 burstcoin java[10362]: [WARNING] 2018-07-22 21:50:26 brs.BlockchainProcessorImpl - Forkprocessing complete.

What should I do to get back in sync?


#2

I’m stuck on the same block, been trying to find a work around all day, no luck yet


#3

pop off hasn’t worked, now trying to bootstrap my DB, looks like it’s a common problem, picking it up on other forums too


#4

bootstrapping the chain worked


#5

This happened to a lot of people. To fix it, in Qbundle go to Database > Bootstrap chain.

This was caused by someone posting something in the Crowdfunding section with a bad signature. It caused a fork in the blockchain and hosed up all kinds of stuff. For instance the burst wallet on the Bittrex exchange is offline (just when I was thinking of buying some more).

There’s a post on Discord about it.
https://www.reddit.com/r/burstcoin/comments/90rg64/please_read_fork_news/


#6

Was using H2 as DB. My bootstrap failed. Switched over to MariaDb and bootstrapped. It is better. Although it seems that some blocks not appearing in Blago Miner’s Console or Miner’s Loge.g., 514989. Does appear in the “Recent Blocks” panel. Seems that blocks such as 514973 and 514972 are MIA also.


#7

What’s the best way to bootstrap BRS 2.2.1 (I’m not using QBundle)?. Poking around the database I’m a bit in the dark even though the schema looks straightforward enough.


#8

I tried DELETEing from block but messed up my database. To re-create I used this sketch:

mysqladmin create brs_master
mysql mysql
> GRANT ALL ON brs_master TO 'brs_user'@'localhost' IDENTIFIED BY '********';
cd /etc/burstcoincg/
$EDITOR brs.properties # to set the new credentials
cd /usr/share/burstcoincg/
./burst.sh  import  mariadb

I’m finally up to block 515452.