Wallet will not sync


#1

I have tried twice to pop off some blocks 100 blocks and 500 blocks and it downloaded the blocks back and then stops at 2018-05-09 14:54:42. Could someone please help?

The MariaDB console says this:

2018-05-12 8:18:44 1308 [Note] C:\Qbundle\MariaDb\bin\mysqld.exe (mysqld 10.1.29-MariaDB) starting as process 5772 …
2018-05-12 8:18:44 1308 [Note] InnoDB: innodb_empty_free_list_algorithm has been changed to legacy because of small buffer pool size. In order to use backoff, increase buffer pool at least up to 20MB.
2018-05-12 8:18:44 1308 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2018-05-12 8:18:44 1308 [Note] InnoDB: The InnoDB memory heap is disabled
2018-05-12 8:18:44 1308 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2018-05-12 8:18:44 1308 [Note] InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2018-05-12 8:18:44 1308 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-05-12 8:18:44 1308 [Note] InnoDB: Using generic crc32 instructions
2018-05-12 8:18:44 1308 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2018-05-12 8:18:44 1308 [Note] InnoDB: Completed initialization of buffer pool
2018-05-12 8:18:44 1308 [Note] InnoDB: Highest supported file format is Barracuda.
2018-05-12 8:18:44 1308 [Note] InnoDB: 128 rollback segment(s) are active.
2018-05-12 8:18:44 1308 [Note] InnoDB: Waiting for purge to start
2018-05-12 8:18:44 1308 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.36-82.2 started; log sequence number 9385492147
2018-05-12 8:18:44 2200 [Note] InnoDB: Dumping buffer pool(s) not yet started
2018-05-12 8:18:44 1308 [Note] Plugin ‘FEEDBACK’ is disabled.
2018-05-12 8:18:44 1308 [Note] Server socket created on IP: ‘::’.
2018-05-12 8:18:44 1308 [Note] C:\Qbundle\MariaDb\bin\mysqld.exe: ready for connections.
Version: ‘10.1.29-MariaDB’ socket: ‘’ port: 3306 mariadb.org binary distribution

On the BSR wallet console it says this:

[SEVERE] 2018-05-12 08:33:34 brs.BlockchainProcessorImpl - Block not accepted
brs.BlockchainProcessor$TransactionNotAcceptedException: Double spending transaction: 17499969334953767682 transaction: {“senderPublicKey”:“b338f1944991e03fa5e12a4293f01e4d2d5cab611519ff3c1afd87956d41b35c”,“signature”:“7326625afa35dea9f5c09b390edea2bfc459f796076ac456d71ad47e6072e8027ba454f11dd0e6026729dc4a9c70f40aaf723d92fe2795c1519018ad645071af”,“feeNQT”:100000000,“type”:0,“version”:1,“ecBlockId”:“14782021270903885196”,“attachment”:{},“subtype”:0,“amountNQT”:17500000000,“recipient”:“8033610128190856183”,“ecBlockHeight”:488529,“deadline”:1440,“timestamp”:118169917}
at brs.BlockchainProcessorImpl.accept(BlockchainProcessorImpl.java:1000)
at brs.BlockchainProcessorImpl.pushBlock(BlockchainProcessorImpl.java:974)
at brs.BlockchainProcessorImpl.lambda$new$7(BlockchainProcessorImpl.java:273)
at brs.util.ThreadPool.lambda$start$0(ThreadPool.java:96)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask.runAndReset(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


#2

This could be because the time of your computer isn’t synced up. This is a little-discussed issue as most of the time, people’s computers are on correct time.

I use this to make sure my time doesn’t drift, setting it to check as frequently as possible.

http://www.timesynctool.com/